Alter aus Geburtsdatum berechnen per Tabellenkalkulation

Um ein Datum in eine Anzahl an vergangenen Jahren umzurechnen bedarf es nur weniger Schritte mit Open Office Calc oder Excel. (Als Grundlage nehme ich Open Office. In Excel dürfte es jedoch keine Unterschiede geben.) Schlaue Menschen nehmen zwar lieber ihre zehn Finger und zählen ab oder beherrschen sogar das Kopfrechnen. Ich möchte hier trotzdem eine tabellenkalkulatorische Lösungen präsentieren, weil ich sie gerade selbst gesucht und dann auch gefunden habe. Praktisch kann so etwas beispielsweise sein, wenn mensch einen Serienbrief erstellen möchte und nicht abzählen möchte.

Ich habe hier folgende Beispieltabelle erstellt, die als Rohdaten einen Namen und ein Geburtsdatum („geb.“) enthält:

Der Name dient nur der Illustration. Alle weiteren Daten („Alter genau“; „Alter“; „Lebensjahr“; „Jünger als 27?“) werden mit Formeln aus dem Gebursdatum errechnet.

Schritt 1: Das genaue Alter
Hierfür bietet Open Office Calc (und auch Excel; das spare ich mir aber hier jeweils zu nennen) die Funktion „BRTEILJAHRE“. Diese berechnet die Differenz zwischen zwei Jahresdaten als Bruchteil von Jahren. Das erste Datum muss älter als das zweite sein. Außerdem kann noch eine so genannte „Basis“ angegeben werden, einen Zahlencode, der die Werte 0; 1; 2; 3; 4 annehmen kann, was im OpenOffice.org-Wiki näher erläutert wird. (Wird die Basis weggelassen wie in diesem Beispiel oder der Wert auf „0″ gesetzt, findet die Berechnung mit 30 Tage langen Monaten statt, für eine genaue Berechnung muss der Basis-Wert „1″ eingegeben werden.)

=BRTEILJAHRE(Ausgangsdatum;Enddatum;Basis) oder vereinfacht
=BRTEILJAHRE(Ausgangsdatum;Enddatum)

Um Paul Pudels Alter heute auszurechnen, müsste also in eine Zelle geschrieben werden:

=BRTEILJAHRE(12.09.1995;05.01.2010)

Als Ergebnis wird der Wert 14,314 (Jahre) ausgegeben. Da mensch das aktuelle Datum ja nicht immer per Hand ändern will, bietet sich hier die Funktion HEUTE an, die ohne Argumente auskommt. Paul Pudels Geburtstag entspricht dem Feld B2. Die Formel lautet dann:

=BRTEILJAHRE($B2;HEUTE())

Das „$“-Zeichen kann entfallen, ist aber hilfreich, wenn der Feldwert bzw. die Formel in ein anderes Feld kopiert wird. (Spalte B bleibt dann unverändert stehen.) Zur Formatierung sei angemerkt, dass die Zellen der Spalte C mitdem Format-Code 0,000 formatiert wurden (Menü > Format > Zellen).

Schritt 2: Das Alter in ganzen Jahren
Hierzu muss das genaue Alter abgerundet werden. Die Funktion hierzu heißt ABRUNDEN. Es gibt zwei Möglichkeiten:

=ABRUNDEN($C2) und
=ABRUNDEN(BRTEILJAHRE($B2;HEUTE())

Die erste (kurze) Variante rundet „Alter genau“ ab, die zweite Variante berechnet den Wert selbst bzw. neu.

Schritt 3: Das Lebensjahr
Hierfür muss zum vorherigen Schritt 1 als SUMME addiert werden.

=SUMME($D2+1) und
=SUMME(ABRUNDEN(BRTEILJAHRE($B2;HEUTE())+1)

Um hinter der ausgegebenen Zahl (In E1 wird „15“ ausgegeben.) noch einen Punkt zu setzen, wird unter Menü > Format > Zellen der Format-Code 0"." angegeben.

Schritt 4: Umwandlung in Text
Als Beispiel, um die Ergebnisse in einen aussagekrräftigen Text umzuwandeln, wurde hier die Frage gewählt, ob die entsprechenden Personen jünger als 27 Jahre alt sind. Hier ist die Wenn-Dann-Sonst-Schleife WENN hilfreich: „Prüfe, ob die Person jünger als 27 ist und wenn ja, gib aus: ‚jünger‘, ansonsten gib aus ‚ZU ALT‘.“ Die WENN-Formel sieht allgemein so aus:

=WENN(Prüfung;Dann;Sonst)

Es bieten sich wieder verschiedene Möglichkeiten der Berechnung:

=WENN($D2<27;"jünger";"ZU ALT") und
=WENN(ABRUNDEN(BRTEILJAHRE($B2;HEUTE()))<27;"jünger";"ZU ALT")

weiterer Schritt: Abgleich meherer Fragen
Werden zwei Fragen gestellt, beispielsweise, ob eine Person jünger als 27 Jahre ist und gerne Nudeln ist, muss zunächst eine weitere Spalte G „Nudeln?“ angelegt werden. In dieser Spalte wird immer „ja“ eingetragen, wenn die Person Nudeln mag. Um die Doppelfrage zu beantworten, ist eine verschachtelte Wenn-Dann-Sonst-Schleife nötig. Open Office Calc rechnet nach dem Muster „Prüfe, ob die Person Nudeln mag und wenn „ja“, dann [prüfe, ob die Person jünger als 27 Jahre alt ist und wenn ja, dann gib aus ‚ja‘, sonst gib aus ‚nein‘], sonst gib aus ‚nein‘.“ In Open Office sieht das so aus:

=WENN($G2="ja";WENN($D2<27;"nein";"ja");"nein") und
=WENN($G2="ja";WENN(ABRUNDEN(BRTEILJAHRE($B2;HEUTE())<27;"nein";"ja");"nein")

Verbesserungsvorschläge und Anregungen sind gern willkommen!

Text und Grafik stehen unter der Creative-Commons-Lizenz by-nc-sa 3.0.


5 Antworten auf „Alter aus Geburtsdatum berechnen per Tabellenkalkulation“


  1. 1 Jugendpresseleiter 06. Januar 2010 um 1:47 Uhr

    Jugendmedienleiter 04.01.10 1. Lebensjahr Mag keine Nudeln

  2. 2 gnurpsnewoel 06. Januar 2010 um 1:55 Uhr

    @Jugendpresseleiter: War das jetzt „mehr als Worte“?

  3. 3 Idiot 26. März 2012 um 0:19 Uhr

    Wie wär’s, wenn Du mal eine Datei dazu posten würdest?

  4. 4 A_Loch 24. März 2015 um 11:49 Uhr

    HÄH???? ich versteh das nicht? Ich m,ach jetz´t gleich schluß mit meinem Live:)
    YOLO BYE

  5. 5 A_Loch 24. März 2015 um 11:57 Uhr

    Ich nochmal. Hat jemand eine Idee wie ich das ganze erledigen kann? Danke schonmal für eure Hilfe,

Antwort hinterlassen

XHTML: Du kannst diese Tags benutzen: <a href=""> <abbr title=""> <acronym title=""> <b> <blockquote> <code> <em> <i> <strike> <strong>


+ zwei = neun